loco/decoder problem to sort please

Post Reply
wattalan
Posts: 33
Joined: Fri Oct 05, 2018 3:54 pm
Location: Seaham Co Durham
Contact:

loco/decoder problem to sort please

#1

Post by wattalan » Tue Oct 16, 2018 4:03 pm

ok i have a class 37 with a ver4 loksound chip fitted
all was well until it went over a point with the inccorect frog polarity
the loco stopped and sound went off
so i clear the short and now the loco wont move
so ive put the loco on my test track reset it with the loksound programmer and it now works all ok

until i put it on my layout which is train controller and a digitrax dcs240 power unit and it wont move all the sounds work as if it was running the engine sound goes up and down with the throttle but the loco wont move all my other locos move so the system is working
put it back on the test track and everthing works
ITS GOT ME STUMPED
cheers Al
using Digikeijs dr5000
using Train Controller for Trains and Icar for running cars etc

brian1951
Site Admin
Posts: 885
Joined: Thu Oct 04, 2018 5:52 pm
Location: Welsh Borders.
Contact:

Re: loco/decoder problem to sort please

#2

Post by brian1951 » Tue Oct 16, 2018 4:10 pm

Alan i would first try another decoder in it first ( non sound will do ) and test on main track to see what happens.

wattalan
Posts: 33
Joined: Fri Oct 05, 2018 3:54 pm
Location: Seaham Co Durham
Contact:

Re: loco/decoder problem to sort please

#3

Post by wattalan » Tue Oct 16, 2018 4:34 pm

the decoder works with the loksound programmer ok
using Digikeijs dr5000
using Train Controller for Trains and Icar for running cars etc

brian1951
Site Admin
Posts: 885
Joined: Thu Oct 04, 2018 5:52 pm
Location: Welsh Borders.
Contact:

Re: loco/decoder problem to sort please

#4

Post by brian1951 » Tue Oct 16, 2018 4:37 pm

ok, but its a case now of finding out if the loco works ok without the sound in on the main track ie if the power is the same as the test track.

wattalan
Posts: 33
Joined: Fri Oct 05, 2018 3:54 pm
Location: Seaham Co Durham
Contact:

Re: loco/decoder problem to sort please

#5

Post by wattalan » Tue Oct 16, 2018 6:20 pm

test track everything works
on digtrax system the sound works but no movement
so i take it the decoder is ok

put a standard horby docoder in the loco and it works on both systems ok
cheers Al
using Digikeijs dr5000
using Train Controller for Trains and Icar for running cars etc

brian1951
Site Admin
Posts: 885
Joined: Thu Oct 04, 2018 5:52 pm
Location: Welsh Borders.
Contact:

Re: loco/decoder problem to sort please

#6

Post by brian1951 » Tue Oct 16, 2018 6:29 pm

That points to the decoder in conjunction with the digtrax are not communicating correctly. I take it you have tried a reset.

wattalan
Posts: 33
Joined: Fri Oct 05, 2018 3:54 pm
Location: Seaham Co Durham
Contact:

Re: loco/decoder problem to sort please

#7

Post by wattalan » Tue Oct 16, 2018 7:14 pm

THANK FOR THE HELP but??
my cockup i was changing some train functions on the loco in train controller (horns/lights etc) and must of got the wrong function address for the cab lights turn the lights off and all works put the cab light on and no movement
put it back on the program track checked the software and function 8 in the programmed software for this sound loco is drive hold
so i change the function 8 to cab lights and now it all works

i have 24 class 37 with sound and for some reason this one is different some sounds are leggoman and some howes

thank god for that it was doing my head in
cheers Al
using Digikeijs dr5000
using Train Controller for Trains and Icar for running cars etc

brian1951
Site Admin
Posts: 885
Joined: Thu Oct 04, 2018 5:52 pm
Location: Welsh Borders.
Contact:

Re: loco/decoder problem to sort please

#8

Post by brian1951 » Tue Oct 16, 2018 7:27 pm

No problem you got there in the end.

Mountain Goat
Posts: 973
Joined: Fri Oct 05, 2018 12:57 pm
Contact:

Re: loco/decoder problem to sort please

#9

Post by Mountain Goat » Tue Oct 16, 2018 11:41 pm

24? Wow! That's impressive. I bet they give quite a sound if they are all idling at the same time! :lol:
Enjoying freelance modelling in 7mm narrow gauge Feel free to ask questions relating to the Mountain Goats Waggon & Carriage Works thread.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest